Last Updated on September 25, 2021 by Admin 1

300-410 : Implementing Cisco Enterprise Advanced Routing and Services (ENARSI) : Part 06

  1. Which command can you use to specify that network 208.15.208.0 belongs to OSPF area 0?

    • router(config)# network 208.15.208.0 area 0
    • router(config-if)# ip ospf area 0
    • router(config)# network 208.15.208.0 255.255.255.0 area 0
    • router(config-router)# network 208.15.208.0 0.0.0.255 area 0
    Explanation:
    You identify the area to which a network belongs with the network area command issued from router configuration mode:

    router(config-router)# network address wildcard-mask area area-id

    To enter router configuration mode, enter the command router ospf process ID in global configuration mode. For this command to be accepted and acted upon by the router, at least one interface on the router must have an IP address assigned and be up.

    The command router(config)# network 208.15.208.0 area 0 is incorrect because it is executed in global configuration mode, as evidenced by the prompt router(config)#.

    The command router(config-if)# ip ospf area 0 is incorrect. This command would be used to configure the router for OSPF and its area. It would also enter configuration mode for that particular process of OSPF so the user can enter additional commands that affect that process. However, this command is missing the process ID.

    The command router(config)# network 208.15.208.0 255.255.255.0 area 0 is incorrect because it is executed in the wrong mode. It is entered in global configuration mode instead of OSPF configuration mode. It also has an incorrect mask. You must use a wildcard mask instead of a regular mask in the network statements for OSPF. In this case, the mask should be 0.0.0.255 instead of 255.255.255.0.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify OSPF operations

  2. Consider the partial output of the show ip bgp command:

    300-410 Part 06 Q02 074
    300-410 Part 06 Q02 074

    Which of the following statements are TRUE about the given output? (Choose all that apply.)

    • The 10.62.7.0 route is learned by the router through an iBGP neighbor.
    • All five routes have been originated by an IGP.
    • The router is aware of the best path for the 61.80.3.0 destination.
    • There are four AS between the router and the 192.177.1.0 subnet.

    Explanation:

    The following statements are TRUE about the given output:

    The 10.62.7.0 route is learned by the router through an iBGP neighbor.
    All five routes have been originated by an IGP.The show ip bgp command displays information about the BGP routing table, including origin type, metric, next-hop addresses for every route learned by BGP, router ID, local preference, and BGP path. In the output, the character i in the first entry of the 10.62.7.0 destination indicates that the route was learned by an iBGP neighbor. The * symbol at the beginning of the routes indicate that they are valid routes, while the > symbol indicate that the route is the current best route.The i at the end of the entries under the Path column indicates that the routes have been originated by an interior gateway protocol (IGP). In the scenario output, all five routes have an i at the end of their respective entries. If the character e appears as the origin code, the routes are considered to have originated from an exterior gateway protocol (EGP). The origin code can also be the ? character, which implies that the origin of the route is unknown.The output also displays the next-hop addresses for the routes. The 200.7.34.0 subnet is a local route, and hence has its next-hop address as 0.0.0.0.The show ip bgp command also displays the local router’s ID (RID), local preference, weight, and next-hop addresses for every route learned by BGP. In this case, the RID of RouterA is 200.17.34.15 and the local preference, weight, and next-hop address for the 10.62.7.0 network are 100, 0, and 10.62.7.78, respectively. The metric and the next-hop address for the BGP routes can also be viewed by using the show ip route bgp command, as follows:RouterA# show ip route bgp
    B 10.62.7.0 [200/0] via 10.62.7.78, 01:34:16
    B 200.17.56.0 [200/0] via 10.62.7.78, 01:34:16
    B 192.177.1.0 [20/100] via 10.62.7.115, 01:34:16The BGP table version can also be displayed by using the show ip bgp neighbors and the show ip bgp summary commands. The show ip bgp neighbors command also displays the address, ASN, and RID of neighbors of the local router, as shown below:RouterA# show ip bgp neighbors
    BGP neighbor is 192.177.1.6, remote AS 200, external link
    BGP version 17, remote router ID 200.17.34.15
    BGP state = Established, table version = 16, up for 01:45:03
    <output omitted>The show ip bgp summary command displays the RID and the BGP table version, as shown in the following output:RouterA# show ip bgp summary
    BGP router identifier 200.17.34.15, local AS number 100
    BGP table version is 17, main routing table version 18
    <output omitted>
    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
    10.62.7.90 17 200 56 55 18 0 0 01:42:13 27
    10.62.7.145 17 300 34 33 18 0 0 00:31:20 0The router is not aware of the best path for the 61.80.3.0 route. The character h appears at the beginning of the entry for the 61.80.30 destination. This means that the route is in the history state currently and that the best route is not known.There are not four AS between the router and the 192.177.1.0 subnet. In the output, the Path column for the 192.1771.1.0 subnet lists four AS numbers. The four AS numbers refer to the ASNs traversed by the route from RouterA to the 192.177.1.0 subnet. The first AS refers to the first neighbor of RouterA; the second AS refers to the neighbor of the first neighbor; and so on. The last AS in the column is the AS of the 192.177.1.0. This implies that there are three AS (1, 2, and 3) that exist between RouterA and the subnet.
    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify eBGP (IPv4 and IPv6 address families)

  3. Which of the following statements is NOT true about BGP peers?

    • eBGP peers use TCP to communicate
    • eBGP peers use port 179 by default
    • eBGP peers do not update the AS_Path attribute before sending updates to another eBGP peer
    • iBGP peers do not update the AS_Path attribute before sending updates to an iBGP peer
    Explanation:
    External BGP (eBGP) peers do update the AS_Path attribute before sending updates to another eBGP peer. This helps to maintain the path back to the source of the update.

    eBGP peers use TCP to communicate, and they do so on port 179 by default.

    Internal BGP (BGP) peers are routers that reside in the same AS. iBGP peers do not update the AS_Path attribute before sending updates to an iBGP peer. That is only done when an update is sent from an eBGP peer to another eBGP peer.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Explain BGP attributes and best-path selection

  4. Which parameter does EIGRP use to compute the bandwidth part of the metric?

    • The maximum bandwidth link in the path, in kilobits per second
    • The minimum bandwidth link in the path, in kilobits per second
    • The average bandwidth of all the links in the path, in kilobits per second
    • The average bandwidth of all the links in the path, in kilobytes per second
    Explanation:
    The minimum bandwidth link, in kilobits per second, is used in the EIGRP metric calculation, because this is the limiting factor in the overall speed of delivery over the path.

    BW = (10,000,000 / bandwidth in Kbps) x 256
    Delay = (delay in microseconds / 10) x 256

    The formula for calculating the EIGRP metric is shown below:

    [K1 x BW + (K2 X BW) / (256 – load) + K3 x delay] X [K5 / (reliability + K4)]

    You should note, however, that when K5 = 0 (as it is by default), a slightly different formula applies.

    When K5 = 0, the EIGRP metric is [K1 X BW + (K2 X BW) / (256 – load) + K3 x delay]

    By default, K1 = 1, K3 = 1, and K2, K4, and K5 = 0.

    Therefore, the default EIGRP metric is BW + Delay, where “BW” and “Delay” are determined according to the formula above.

    The final formula is shown below:

    [10,000,000 / (bandwidth in Kbps) + (delay in microseconds) / 10] * 256

    These usually are derived from the values listed in the show interfaces command.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Describe and optimize EIGRP metrics

  5. Examine the sample output of the show ip eigrp topology command.

    300-410 Part 06 Q05 075
    300-410 Part 06 Q05 075

    The network 65.0.0.0 is one of the advertised networks in the routing table. What does the value 128256 represent?

    • The advertised distance
    • The feasible distance
    • The administrative distance
    • The hop count
    Explanation:
    The number 128256 after the advertisement for network 65.0.0.0 represents the advertised distance. The advertised distance is the metric that the neighboring router advertised to the local router.

    The feasible distance is the metric that the local router would advertise to the next router. Feasible distance is represented by the number preceding the advertised distance number in the output.

    The administrative distance is a number that represents the trustworthiness of a routing protocol. It allows a router to decide which routing protocol’s route to use in the event that more than one protocol advertises a route to the same network. The administrative distance is not shown in the output of the show ip eigrp topology command.

    Hop count is a simple metric that RIP uses to compare multiple routes to the same network.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify policy-based routing

  6. Consider the following commands:

    RouterA(config)# router ospf 10
    RouterA(config-router)# redistribute eigrp 20 metric 30

    What does the value of 30 represent?

    • It identifies the seed metric associated with OSPF routes that are redistributed into EIGRP.
    • It identifies the seed metric associated with EIGRP routes that are redistributed into OSPF.
    • It identifies the amount that the existing EIGRP metric will increment as it is redistributed into OSPF.
    • It specifies that routes that contain metrics of less than 30 will be redistributed from OSPF into EIGRP.
    Explanation:
    The value 30 represents the seed metric for routes that are redistributed from EIGRP into OSPF.

    When configuring the OSPF process, the redistribute command is used to identify the source protocol, its AS or process ID, and several other optional parameters, such as metric. The default seed metric for all routing protocols except BGP is 20. When redistributing BGP, the default seed metric is 1.

    It does not identify the seed metric associated with OSPF routes that are redistributed into EIGRP. The command is redistributing EIGRP into OSPF, not OSPF into EIGRP.

    It does not identify the amount that the existing EIGRP metric will increment as it is redistributed into OSPF. A seed metric value is an absolute value not incremental.

    It does not specify that routes that contain metrics of less than 30 will be redistributed from OSPF into EIGRP. It not used to filter routes.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify redistribution between any routing protocols or routing sources 

  7. Which command can you use to display the area border routers (ABRs) and the routes to them?

    • show ip ospf dr
    • show ip opsf bdr
    • show ip ospf database
    • show ip ospf border-routers

    Explanation:

    The correct answer is show ip ospf border-routers. The following commands are available to verify OSPF configurations:

    show ip ospf border-routers – displays internal ISPF routing table entries for an ABR.
    show ip ospf virtual-links – displays the current state of OSPF virtual links.
    show ip ospf – displays information about the router’s role and each area to which the router is connected.
    show ip ospf database – displays the contents of the router’s topological database. Note that a number of keywords can be used with the show ip ospf database command to get specific information.The command show ip ospf dr is not correct because dr is not a parameter of the show ip ospf command.The command show ip ospf bdr is not correct because bdr is not a parameter of the show ip ospf command.
    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify network types, area types, and router types

  8. If the following protocols are redistributed into OSPF, which protocol will receive a metric of 1 if none is specified, rather than the default metric of 20?

    • EIGRP
    • RIP
    • IGRP
    • BGP
    Explanation:
    Border Gateway Protocol (BGP) routes that are redistributed into OSPF will be marked with a metric of 1 if no other metric is specified. All other routing protocols will receive a metric of 20 when redistributed into OSPF.

    A metric can be manually specified when redistributing the route, as shown below:

    router5(config)# router ospf 10
    router5(config-router)# redistribute bgp 120 metric 5

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify redistribution between any routing protocols or routing sources

  9. Routers R1 and R2 are being added to the network shown in the exhibit.

    300-410 Part 06 Q09 076
    300-410 Part 06 Q09 076

    The addresses of their respective interfaces have already been configured as follows:
    R1: E0 192.168.4.5/30
    R2: E0 192.168.4.6/30
    R2: E1 192.168.72.6/30

    You have been assigned to complete the following as a part of implementing OSPF area 5:
    The E0 interface on R1 should be in area 5.
    The E0 interface on R2 should be in area 5.
    The mask used with the OSPF configuration should only include the addresses for R1 and R2.
    Area 5 should not allow any external or inter-area routes (except for the default route).

    Which commands are required to accomplish this set of requirements? (Choose all that apply.)

    • R1# configure terminal
      R1(config)# router OSPF 1
      R1(config-router)# network 192.168.4.4 0.0.0.3 area 5
      R1(config-router)# area 5 stub
      R1(config-router)# end
      R1# copy running-config startup-config
    • R1# configure terminal
      
      R1(config)# router OSPF 1
      
      R1(config-router)# network 192.168.4.4 0.0.0.3 area 5
      
      R1(config-router)# area 5 stub no-summary
      
      R1(config-router)# end
      
      R1#copy running-config startup-config
    • R1# configure terminal
      
      R1(config)# router OSPF 1
      
      R1(config-router)# network 192.168.4.4 0.0.0.4 area 5
      
      R1(config-router)# area 5 stub
      
      R1(config-router)# end
      
      R1# copy running-config startup-config
    • R2# configure terminal
      R2(config)# router OSPF 1
      R2(config-router)# network 192.168.4.4 0.0.0.3 area 5
      R2(config-router)# area 5 stub no-summary
      R2(config-router)# end
      R2# copy running-config startup-config
    • R2# configure terminal
      
      R2(config)# router OSPF 1
      
      R2(config-router)# network 192.168.4.4 0.0.0.3 area 0
      
      R2(config-router)# area 0 stub no-summary
      
      R2(config-router)# end
      
      R2# copy running-config startup-config
    • R2# configure terminal
      
      R2(config)# router OSPF 1
      
      R2(config-router)# network 192.168.4.4 0.0.0.3 area 5
      
      R2(config-router)# area 5 stub
      
      R2(config-router)# end
      
      R2# copy running-config startup-config
    Explanation:
    The following set of commands will configure R1 properly and satisfy the requirements:

    R1# configure terminal
    R1(config)# router OSPF 1
    R1(config-router)# network 192.168.4.4 0.0.0.3 area 5
    R1(config-router)# area 5 stub
    R1(config-router)# end
    R1# copy running-config startup-config

    The configure terminal command enters global configuration mode, from which the router ospf 1 command can be executed to enable OSPF process 1. The network command allows the192.168.4.4/30 network to join OSPF area 5 and uses a wildcard mask (0.0.0.3) that only includes the E0 interfaces on R1 and R2. The area 5 stub command configures R1 as an internal router in a totally stubby area, which is necessary because no external or inter-area routes are allowed. The final two commands exit OSPF configuration mode and save the configuration.

    The following set of commands will configure R2 properly and satisfy the requirements:

    R2# configure terminal
    R2(config)# router OSPF 1
    R2(config-router)# network 192.168.4.4 0.0.0.3 area 5
    R2(config-router)# area 5 stub no-summary
    R2(config-router)# end
    R2# copy running-config startup-config

    The configure terminal command enters global configuration mode, from which the router ospf 1 command can be executed to enable OSPF process 1. The network command allows the192.168.4.4/30 network to join OSPF area 5, and uses a wildcard mask (0.0.0.3) that only includes the E0 interfaces on R1 and R2. The area 5 stub no-summary command configures R2 as an area border router (ABR) in a totally stubby area, which is necessary because no external or inter-area routes are allowed. The final two commands exit OSPF configuration mode and save the configuration.

    The wildcard mask on both network statements, 0.0.0.3, is the wildcard equivalent of a 255.255.255.252 mask (/30). When used with the network address 192.168.4.4, this mask will only allow two addresses in the area, 192.168.4.5 and 192.168.4.6, as per the scenario requirements.

    The command set that executes the area 5 stub no-summary command on router R1 is incorrect because R1 is an internal router and does not require the no-summary keyword. The no-summary keyword is only required on the ABR when configuring a totally stubby area.

    The command set that executes the network 192.168.4.4 0.0.0.4 area 5 command on router R1 has the wrong wildcard mask.

    The command set that executes the network 192.168.4.4 0.0.0.3 area 0 command on router R2 is incorrect because the area should be area 5, not area 0.

    The command set that executes the area 5 stub command on router R2 is incorrect becauseR2 is an ABR router and requires the no-summary keyword when configuring a totally stubby area.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify network types, area types, and router types

  10. You need to configure eBGP on the rtrA and rtrB routers, as shown in the following image:

    300-410 Part 06 Q10 077
    300-410 Part 06 Q10 077

    You have configured eBGP on rtrA through the following commands:

    rtrA(config)# router bgp 501
    rtrA(config)# neighbor 201.60.3.2 remote-as 505

    While configuring eBGP on rtrB, you need to ensure that updates about the 192.168.58.0/24 and the 192.168.127.0/24 subnets are sent to rtrA with a metric of 300. In addition, rtrB should send updates about the 172.161.94.0/24 subnet are sent with a metric of 500.

    Which of the following set of commands would NOT be part of the set used to correctly configure eBGP on rtrB?

    • access-list 1 permit 192.168.0.0 0.0.255.255
      access-list 2 permit 172.161.94.0 0.0.0.255
      router bgp 505
      neighbor 201.60.3.1 remote-as 501
      neighbor 201.60.3.1 route-map change_parameters in
    • access-list 1 permit 192.168.0.0 0.0.255.255
      access-list 2 permit 172.161.94.0 0.0.0.255
      router bgp 505
      neighbor 201.60.3.1 remote-as 501
      neighbor 201.60.3.1 route-map change_parameters out
    • route-map change_parameters permit 10
      match ip-address 2
      set metric 500
    • route-map change_parameters permit 20
      match ip-address 1
      set metric 300
    Explanation:
    The following command set would NOT be used because it only applies the access list route-map change_parameters inbound instead of outbound, as would be required:
    300-410 Part 06 Q10 078
    300-410 Part 06 Q10 078

    The ACL 1 allows the 192.168.58.0/24 and the 192.168.127.0/24 subnets, while the ACL 2 allows the 172.161.94.0/24 subnet. The neighbor route-map command specifies a route-map named change_parameters for the 201.60.3.1 BGP peer. The out keyword at the end of the command indicates that the route-map is applied only to the updates sent by rtrB, and not received by rtrB.

    In the following command, the route map change_parameters is defined with the permit keyword. The permit keyword indicates that if a match occurs, the actions specified in the set sub-command are executed:

    route-map change_parameters permit 10
    match ip-address 2
    set metric 500

    In this case, this command checks if the IP address of the subnets advertised to rtrA is in the 172.161.94.0/24 subnet (specified by ACL 2). If the IP address matches, then the metric of those routes are set to 500.

    In the following command, the route map change_parameters is defined with the permit keyword:

    route-map change_parameters permit 20
    match ip-address 1
    set metric 300

    In this case, this command checks if the IP address of the subnets advertised to rtrA is in the 192.168.58.0/24 or the 192.168.127.0/24 subnets (specified by ACL 1) If the IP address matches, then the metric of those routes are set to 300.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify eBGP (IPv4 and IPv6 address families)

  11. For a non-ISP autonomous system (AS), which combination of two conditions will require redistribution from BGP into Interior Gateway Protocol (IGP)? (Choose two.)

    • All routers run BGP.
    • Not all routers run BGP.
    • No knowledge of external routes is required inside the AS.
    • Routers inside the AS require knowledge of external routes.

    Explanation:

    For non-ISP autonomous systems (AS), redistribution into IGP is required when BOTH of the following conditions exist:

    Not all routers run BGP
    Knowledge of external routes is required inside the ASNote: Redistribution of any BGP routes into your IGP can cause serious problems, even if your internal routers can handle the load. This should be done rarely, if at all. If you do decide to do this, configure heavy filtering to allow only very few routes into OSPF or EIGRP so as not to overwhelm those protocols. For instance, do it only for a select group of networks for which optimal routing is critical.
    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify redistribution between any routing protocols or routing sources

  12. Your network has an OSPF area that connects to an EIGRP area at two points, Router A and Router B. You directed your assistant to set up these two routers in order to have traffic load-balanced between the two entry points. However, you discover that all traffic is going through Router A. When you view the results of the show run command for each device, you get the partial output shown below:

    300-410 Part 06 Q12 079
    300-410 Part 06 Q12 079

    What action should be performed to make traffic use both routes to the EIGRP area?

    • change the metric for EIGRP to 50 on Router A
    • change the metric for EIGRP to 45 on Router B
    • change the metric type to Type 1 on Router A
    • change the metric type to Type 1 on Router B
    Explanation:
    You should change the metric for EIGRP to 50 on Router A. The metric can be defined when configuring the redistribution of one routing protocol into another. A lower metric will cause traffic to be routed in that direction. Therefore, to make the paths from the two routers equal, you should raise the metric on Router A to 50 to match that of Router B.

    You should not lower the metric on Router B to 45. It will still be a higher metric than that of A and traffic will still go in that direction.

    You should not change the metric type on either router. The metric type determines whether the downstream OSPF routers should add their cost to the total cost to get to the ASBR when computing cost. In this scenario, Router A and Router B are both ASBRs. When set to Type 1, downstream OSPF routers do add their metric. With Type 2, they simply use the configured metric. If you want true load balancing, you should leave the metric type set to Type 2, since you have no information on the cost from the other routers to the ASBRs. However, when Type 1 is used, you must also take into consideration the metric from the other routers to the ASBR when determining the true cost to leave the OSPF area.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify redistribution between any routing protocols or routing sources

  13. Which command can you use to display information about OSPF virtual links?

    • debug ip ospf adj
    • show ip ospf [process-id]
    • show ip ospf virtual-links
    • show ip ospf border-routers
    Explanation:
    The correct answer is show ip ospf virtual-links. The show ip ospf virtual-links command displays the current state of OSPF virtual links, as shown below.
    300-410 Part 06 Q13 080
    300-410 Part 06 Q13 080

    The following additional commands are available to verify OSPF configurations: show ip ospf border-routers, debug ip ospf adj, and show ip ospf.

    The show ip ospf border-routers command displays internal OSPF routing table entries for an ABR, as shown below.

    router10#show ip ospf border-routers
    Codes: i – Intra-area route, I-Inter-area route

    Type Dest Address Cost NextHop Interface ABR ASBR Area SPF
    i 2.2.2.2 10 192.1.1.199 Ethernet 2 TRUE FALSE 0 3
    i 3.2.2.2 10 192.1.1.200 Ethernet 2 TRUE FALSE 0 3

    The show ip ospf command displays information about the router’s role and each area to which the router is connected, as shown below.

    The debug ip ospf adj command displays information about the state of neighbor adjacencies, as shown below.

    R3#debug ip ospf adj
    OSPF adjacency events debugging is on

    00:54:04: OSPF: Rcv pkt from 172.12.23.2, Ethernet0, area 0.0.0.1 : src not on the same network

    In the above example, either the IP address or the subnet mask is misconfigured on either this router or the neighbor.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify network types, area types, and router types

  14. View the sample output of the debug ip eigrp command.

    300-410 Part 06 Q14 081
    300-410 Part 06 Q14 081

    What is the significance of the number 4294967295 as shown in the output?

    • It represents the unreachable metric for EIGRP.
    • It represents the administrative distance for EIGRP.
    • It represents a reachable metric for the given network.
    • It represents one of the link characteristics that EIGRP uses to calculate the metric.
    Explanation:
    The value 4294967295 in the debug ip eigrp output represents the unreachable metric for EIGRP. This means that the network has become unavailable and cannot be reached. In this output, the M represents the local metric, and the SM represents the metric that was reported by the neighbor that advertised the network to the local router.

    The administrative distance (AD) for internal EIGRP is 90.

    The link characteristics that are used in the EIGRP calculation are shown following the dash after the M and SM values (1657856 4294967295). By default, EIGRP only uses bandwidth and delay in its calculation.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Describe and optimize EIGRP metrics

  15. The network administrator has configured router R2 to redistribute a newly installed EIGRP network into their core OSPF network. The redistributed networks and subnets are not properly appearing in the routing tables of the other routers. The following output displays partial configuration for router R2:router ospf 10

    redistribute eigrp 50 metric 100 metric-type 1

    network 192.16.31.0 0.0.0.255

    What two modifications would correct the problem? (Choose two.)

    • Change the EIGRP AS number from 50 to 10
    • Change the AS number specified for OSPF to 50
    • Add the command network 10.0.0.0 0.0.0.255
    • Add the command network 10.0.0.0 255.255.255.0
    • Add the level-1-2 keyword to the redistribute command
    • Add the subnets keyword to the redistribute command
    • Change the command network 192.16.31.0 0.0.0.255 to include the area keyword and value
    Explanation:
    The R2 router will not form adjacencies with neighboring routers in the area if the area IDs do not match. The area keyword in the network command is missing from the initial router R2 configuration. The correct command would be:

    R2(config)# network 192.16.31.0 0.0.0.255 area 1

    Secondly, the subnets keyword should be used in the redistribute command to ensure that all of the subnets in the 10.0.0.0/8 are redistributed into OSPF. For example, you would use the following commands to redistribute EIGRP autonomous system (AS) 50 networks and subnetworks into OSPF with a metric of 100 and advertise them as external Type 1 routes:

    R2(config)# router ospf
    R2(config-router)# redistribute eigrp 50 metric 100 metric-type 1

    The complete syntax for the redistribute command when used in OSPF is as follows:

    redistribute protocol [process-id] [metric metric-value] [metric-type type-value] [subnets]

    The command parameters are:

    protocol – Identifies the source protocol, such as BGP, connected, EIGRP, IGRP, ISIS, OSPF, static, or rip.
    process-id – Depending on the routing protocol, identifies the source autonomous system number or process ID.
    metric – Identifies the seed metric for the redistributed route. The default is 0.
    metric-type – For OSPF, it identifies the redistributed routes as either external Type 1 or Type 2 routes. The default is Type 2.
    subnets – Optional keyword for use with OSPF to indicate that the scope of the networks to be redistributed also includes subnets.

    Objective:
    Layer 3 Technologies

    Sub-Objective:
    Configure and verify redistribution between any routing protocols or routing sourcesReferences:
    Cisco > Cisco IOS IP Routing: Protocol-Independent Command Reference > redistribute (ip)

  16. A neighboring EIGRP router fails. Its advertised distance (AD) to network 10.10.10.0 was 2 and the feasible distance (FD) was 3.Which route will be used to route packets destined for network 10.10.10.0 if the other routes have the following feasible and advertised distances respectively to the destination network?

    • FD-6
      AD-3
    • FD-4
      AD-1
    • FD-5
      AD-3
    • FD-4
      AD-3
    Explanation:
    When EIGRP loses it best route, called the successor route, it will then use a feasible successor route, if available, to route the packets to that destination. To be considered a feasible successor, the advertised distance, which is the neighboring router’s distance, needs to be less than the feasible distance, which is the local router’s own metric.

    In this scenario, the feasible distance is 3. The only available feasible successors are the ones that have the advertised distance/feasible distance of 1/4 and 2/4.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify policy-based routing

  17. You have two routers connected to each other that are both running the EIGRP protocol. The routers have built a neighbor relationship and are exchanging routing information. You execute the following command on the EIGRP process on Router 1:

    router1(config)# router eigrp 100
    router1(config-router)# passive-interface

    What will be the effect of this command?

    • Only routing advertisements from Router 1 to Router 2 will be prevented.
    • Only router advertisements to and from Router 1 will be prevented.
    • All hellos and routing updates will be prevented, and the neighbor relationship between Router 1 and Router 2 will be broken.
    • Hellos will be prevented, but routing updates will continue to be sent out.
    Explanation:
    The effect of the passive-interface command is dependent on the routing protocol. With RIP, the command prevents the sending of route updates, but does not prevent the reception of route updates. With EIGRP, the passive-interface command prevents both the sending and receiving of route updates, and also the sending of hellos. Without hello packets, the routers are unable to maintain the neighbor relationship, upon which all communications including route updates depend.

    If the intent was to preventing routing updates from Router 1 to Router 2 while still allowing updates from Router 2 to Router 1, the routing updates must be filtered out and denied on Router 1 with a distribute list, as shown in the following command set:

    router1(config)access-list 101 deny any
    router1(config)#router eigrp 100
    router1(config-router)distribute-list 101 out

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Troubleshoot passive interfaces

  18. You are the network administrator for a corporate organization. You changed the BGP configuration, then executed the following command on the rtrA router:clear ip bgp 172.161.18.5 soft outWhat is the result of this command?

    • The outbound session between rtrA and 172.161.18.5 is cleared and reset.
    • The inbound session between rtrA and 172.161.18.5 is cleared and reset.
    • The outbound session between rtrA and 172.161.18.5 is cleared.
    • The inbound session between rtrA and 172.161.18.5 is cleared.
    Explanation:
    The outbound TCP session between rtrA and 172.161.18.5 is cleared as a result of the given command. The given command is a variation of the clear ip bgp command.

    The clear ip bgp command allows you to clear and reset the sessions or routing updates in BGP routers so that changes in the BGP configuration can take effect. You can use this command to clear and reset the sessions for all neighbors, a specific neighbor, or a group of neighbors. Use an asterisk (*) or the group name instead of the IP address to apply the command on all the neighbors of a router or a particular peer group, respectively.

    For example, if you execute the clear ip bgp * command, all the sessions currently active are cleared and reset. If you use the clear ip bgp 172.161.18.5 command on rtrA, the current session between rtrA and its neighbor 172.161.18.5 is cleared and reset. Such a reset of sessions is known as hard reset. When hard resets are performed, the neighbor relationship is broken and must be reestablished.

    The soft keyword, which is optional, indicates a soft reset. This keyword allows you to clear the BGP table without resetting the session. If you do not use this keyword, the sessions are cleared and then reset with a hard reset.

    The out keyword specifies that the command should be applied to only outbound sessions. If you use the in keyword, the command is applied to only inbound sessions.

    The outbound TCP session between rtrA and 172.161.18.5 is not cleared and reset by the given command. If the clear ip bgp 172.161.18.5 out command was used, then the outbound session between rtrA and 172.161.18.5 would be both cleared and reset.

    The inbound TCP session between rtrA and 172.161.18.5 is not cleared and reset by the given command. If the clear ip bgp 172.161.18.5 in command were used, then the inbound TCP session between rtrA and 172.161.18.5 would be cleared and then reset.

    The inbound TCP session between rtrA and 172.161.18.5 is not cleared by the given command. If the in keyword were used instead of the out keyword in the given command, the outbound TCP session between the rtrA and 172.161.18.5 would be cleared.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Describe, configure, and verify BGP peer relationships and authentication

  19. You are configuring Open Shortest Path First (OSPF) protocol for IPv6 on Router5. The router has two interfaces, which have been configured as follows:S0/0 – 192.168.5.1/24S0/1 – 10.0.0.6/8You would like OSPF to route for IPv6 only on the S0/0 network and not route for IPv6 on the S0/1 network. The process ID you have chosen to use is 25. You do not want to apply an IPv6 address yet.Which of the following command sets would enable OSPF for IPv6 as required?

    • Router5(config)#ipv6 ospf 25
      
      Router5(config)# network 192.168.5.0
    • Router5(config)#ipv6 ospf 25
      
      Router5(config)#router-id 192.168.5.1
    • Router5(config)#ipv6 unicast-routing
      Router5(config)#ipv6 router ospf 25
      Router5(config-rtr)#router-id 1.1.1.1
      Router5(config)#interface S0/0
      Router5(config-if)#ipv6 ospf 25 area 0
    • Router5(config)#ipv6 unicast-routing
      
      Router5(config)#ipv6 ospf 25
      
      Router5(config-rtr)#router-id 1.1.1.1
    Explanation:
    The correct command sequence would be as follows:

    Router5(config)# ipv6 unicast-routing
    Router5(config)# ipv6 router ospf 25
    Router5(config-rtr)# router-id 1.1.1.1
    Router5(config)# interface S0/0
    Router5(config-if)# ipv6 ospf 25 area 0

    The first line enables IPv6 routing with the ipv6 unicast-routing command. The second line enables OSPF routing for IPv6 with the ipv6 router ospf command. The third assigns a necessary router ID (which was chosen at random) with the router-id command. The last two lines enable OSPF for area 0 on the proper interface.

    The following command set is incorrect because it does not enable OSPF routing for IPv6, assign a necessary router ID, or enable OSPF for area 0 on the proper interface:

    Router5(config)# ipv6 ospf 25
    Router5(config)# network 192.168.5.0

    This command set also displays incorrect use of the network command. The network command would be used with OSPF v2.

    The following command set fails to enable OSPF routing for IPv6, assign a necessary router ID, or enable OSPF for area 0 on the proper interface:

    Router5(config)# ipv6 ospf 25
    Router5(config)# router-id 192.168.5.1

    It also assigns the router ID under global configuration mode, rather than under router ospf 25 configuration mode as required.

    The following command set fails to enable OSPF for area 0 on the proper interface:

    Router5(config)# ipv6 unicast-routing
    Router5(config)# ipv6 ospf 25
    Router5(config-rtr)# router-id 1.1.1.1

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Configure and verify OSPF for IPv6

  20. Refer to the following exhibit, where three routers have EIGRP for IPv6 enabled on them:

    300-410 Part 06 Q20 082
    300-410 Part 06 Q20 082

    What is the next-hop address when rtrB advertises the 2001:5050:D402:B333::/64 IPv6 subnet to rtrC?

    • FE80::3030:3030:3030/64
    • FE80::3230:3030:3030/64
    • FE80::3030:30FF:FE30:3030/64
    • FE80::3230:30FF:FE30:3030/64
    Explanation:
    The next-hop address when rtrB advertises the 2001:5050:D402:B333::/64 IPv6 subnet to rtrC is FE80::3230:30FF:FE30:3030/64. In routers with EIGRP for IPv6 enabled on them, the next-hop address is the IP address of the interface that advertises routes. The next-hop addresses should be link-local addresses. Link-local addresses are IPv6 unicast addresses that are automatically assigned to the router interfaces. These addresses have the FE80::/10 prefix and the EUI-64 standard interface address.

    EUI-64 is an IEEE standard that allows the determination of an IPv6 address from the MAC address of an interface. The 64 most significant bits should be specified in the ipv6 address command. The 64 least significant bits are determined by using the EUI-64 standard. The steps to determine the 64 least significant bits are as follows:

    Divide the 48-bit MAC address into two 24-bit parts.
    Embed FFFE (16 bits) between the two parts resulting in a 64-bit address.
    If required, toggle the seventh bit of the first octet in the address. In EUI-64 format, if the seventh bit is 0, then the address is local. If the seventh bit is 1, the address is global.In this case, when rtrB advertises any route to rtrC, it advertises the interface with the MAC address 3030.3030.3030 as the next-hop. When the given steps are performed on the MAC address, it result in the EUI-64 standard address 3230.30FF.FE30:3030. This address is then appended to the FE80::/10 prefix. The resultant IPv6 link-local address of the interface is FE80::3230.30FF.FE30:3030/10.

    The remaining three options are incorrect as their interface address is not in the EUI-64 standard.

    Objective:
    Layer 3 Technologies
    Sub-Objective:
    Identify IPv6 addressing and subnetting